Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 13, 2026 - 11:00 UTC
Scheduled
Location - Boden, Sweden
Maintenance Window - * Boden: 13 April 2026
Start/End Times * Start: 11:00 UTC * End: 11:30 UTC
Description of Change - This is needed to enhance TCP performance on IPv4 to the Internet and address performance problems with non‑TCP protocols across IPv4 and IPv6 .
Expected Impact - * There will be a brief interruption in connectivity to all systems for approximately 5 minutes
We appreciate your understanding and apologize for any inconvenience this may cause.
If you have any concerns during this maintenance window, please contact Taiga Cloud Customer Support via the ticket portal or email cloud-support@taigacloud.com.
Posted Apr 02, 2026 - 15:06 UTC
This scheduled maintenance affected: Taiga Cloud Network (Availability Sweden (cluster ndcloud-arcticcircle), Availability Sweden (cluster ndcloud-arcticband), Availability Sweden (cluster ndcloud-freyr), Availability Sweden (cluster ndcloud-loki), Availability Sweden (cluster ndcloud-thor), Availability Sweden (cluster ndcloud-ragnar)).