Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 15, 2026 - 08:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 14, 2026 - 08:37 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 14, 2026 - 08:37 UTC
Scheduled
Urgent power maintenance taking place at our London East data center in January 2026. This work is required to support the migration of power infrastructure and will affect both A and B power supplies on separate dates.
Each power feed will be isolated individually during its scheduled window. During these periods, systems will operate solely on the remaining power supply.
Maintenance Schedule A Power Supply: January 28, 2026 — 08:00 to 18:00 Contingency Window: January 29, 2026 — 08:00 to 18:00
B Power Supply (Level 11): February 01, 2026 — 08:00 to 18:00 Contingency Window: February 02, 2026 — 08:00 to 18:00
If you have any concerns during this maintenance window, please contact Taiga Cloud Customer Support via the ticket portal or email cloud-support@taigacloud.com.
Posted Dec 29, 2025 - 12:31 UTC
This scheduled maintenance affects: Taiga Cloud Network (Availability United Kingdom (cluster ndcloud-njoerd)).