Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2026 - 07:00 UTC
Scheduled
Maintenance Window: 12th March 2026 - 13rd March 2026
Location & Affected Areas: • Site: nLighten Chester - United Kingdom • Impacted Area: Data Hall 2
72 x RDHX associated with Northern data
Please be advised that nLighten and our specialist vendor will be carrying out preventative maintenance works to the seventy-two number RDHX associated with the Northern data infrastructure. nLighten strives to perform the Scheduled Maintenance Activity without impact on the Services.
If you have any concerns during this maintenance window, please contact Taiga Cloud Customer Support via the ticket portal or email cloud-support@taigacloud.com.
Posted Feb 13, 2026 - 07:35 UTC
This scheduled maintenance affected: Taiga Cloud Network (Availability United Kingdom (cluster ndcloud-balder)).