DC PowerStation - Intrusive HV Maintenance

Scheduled for Mar 12, 05:00 UTC  -  Mar 15, 05:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 17, 2025 - 10:13 UTC

Scheduled

Maintenance Window:
• Start Date: 12th March 2025 – 05:00 GMT
• End Date: 14th March 2025 – 22:00 GMT
• Duration: 3 Days
• Maintenance Time: 05:00 – 22:00 GMT Daily

Location & Affected Areas:
• Site: Global Switch - London East – PowerStation ‘B’

This is a scheduled critical maintenance activity involving PowerStation ‘B’ Output Panel B/D2 Bus Coupler B/DR/5 to B/DR/6 & BA/IT/Board LHS. The activity includes:
• Pre- and post-maintenance functional checks
• Protection testing
• Busbar inspections
• Isolation of HV Bus Couplers B/DR/5 to B/DR/6
• System validation and reinstatement procedures

This is a standard 5-year intrusive maintenance procedure conducted by Cophill Power Engineering (Q24-0362) and CBRE onsite maintenance teams.

• Medium Risk Level: The maintenance will result in a temporary reduction in resilience but will maintain an N+2 backup system throughout.
• The system operates on a Closed Ring topology, and during maintenance, an Open Ring configuration will be in place to ensure continuous service.
• Only one side of the system will be worked on at any given time, ensuring minimal disruption.
• In the event of a fault, some floors may experience a loss of ‘A’ supply, but DRUPS backup remains in place.
• No expected impact on ‘B’ supply areas.
Posted Feb 17, 2025 - 10:11 UTC