Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 03, 2026 - 07:01 UTC
Scheduled
Maintenance Window: * 3rd June 2026, 07:00–09:00 UTC
Reason for Maintenance: We will be performing planned maintenance to update the public Taiga Cloud service domains as part of ongoing platform improvements.
Customers using the existing portal URL will be redirected where possible to minimise disruption
Expected Duration: Up to 2 hours.
Expected Impact: We expect minimal customer impact during this maintenance. However, customers may experience a short period where the portal or API access is temporarily unavailable while the change is completed.
Mitigation Measures: The change will be carried out during a planned maintenance window. We will monitor the platform throughout the maintenance and perform validation checks once the change is complete.
Where possible, access from existing public URLs will continue to redirect to the new service domains to reduce disruption.
Communication Plan: We will provide updates during the maintenance window and confirm once the work has been successfully completed.
If you have any concerns during this maintenance window, please contact Taiga Cloud Customer Support via the ticket portal or email cloud-support@taigacloud.com.
Posted May 22, 2026 - 10:17 UTC
This scheduled maintenance affected: Taiga Cloud API.